基于衰老更新机制的移动IPv6协议改进
2011-08-16胡清桂
胡清桂
(内江师范学院,四川内江641112)
随着Internet技术的迅速发展,便携计算机等移动设备普遍使用,用户对设备的移动性要求越来越高。下一代网络协议IPv6为节点移动性的实现提供了有力的支持。目前,IETF已经制定了移动IPv6的正式标准(MIPv6-RFC3775[1])和3个相关标准:移动IPv6的快速切换(FMIPv6-RFC4068)、层次移动IPv6的移动性管理(HMIPv6-RFC4140)、网络移动(NEMO-RFC3963[2]),这些标准给人们展示了移动IPv6的诱人前景,但它的发展还只是处在起步阶段,还需要完善和改进。
1 移动IPv6的通信原理
1.1 移动IPv6的基本概念
按照传统的移动IPv6协议,它有以下几个基本概念:
1)移动节点:即移动上网设备,通常称之为MN[1]。
2)家乡地址:移动节点在家乡网络的长期IP地址,它是固定不变的[1]。
3)转交地址:移动节点在外地网络上获得的临时 IP 地址[1]。
4)家乡代理:家乡网络中特定路由器[1]。
5)通信对端:指与移动节点进行通信的网络设备[1]。
1.2 移动IPv6的通信原理
移动节点在本地网络时,采用传统的寻址机制收发数据。当移动节点离开本地网络连接到外地网络时,它根据IPv6定义的地址自动配置方法获得一个临时IP地址,即转交地址(CoA),并将当前的转交地址通知家乡代理和通信对端,然后进行通信[2]。
在标准移动IPv6协议中,每一个移动节点都拥有一个基于其家乡网络地址前缀的永久性IP地址,即家乡地址[3]。当移动节点位于其家乡网络中时,它就是一个固定节点,不执行任何移动IP的功能。当它移动到外地网络时,它根据IPv6定义的地址自动配置方法获得转交地址。然后移动节点向家乡代理和通信对端发送关于转交地址的更新消息,使家乡代理和通信对端及时得到移动节点当前的网络接入点[3]。……
